Madabout Kitcars Forum

Madabout Kitcars Forum (http://www.madabout-kitcars.com/forum/index.php)
-   Marlin 5exi builds (http://www.madabout-kitcars.com/forum/forumdisplay.php?f=11)
-   -   Which Fuel Pump/Sender Unit (http://www.madabout-kitcars.com/forum/showthread.php?t=5452)

EXI Turbo 1st June 2015 18:17

Which Fuel Pump/Sender Unit
 
Ever since I can remember there has been a smell of petrol coming from the unit where it attaches to the fuel tank.

I have removed it numerous times and tried to seal it with every product I can find on the market but to no avail. It is now getting worse and I think it may be the unit itself as the petrol seems to be sitting on it rather than the fuel tank as you would expect if it was the seal between the two.

I have now decided to replace it but wondered which one I should be using. I currently have one from a 1.6L rover 400 but as I have the 2lt turbo lump fitted was thinking I might need something with a bit more oomph.

Any thoughts/experience ?

thanks

bigrich 1st June 2015 22:39

Hi,

I'm running the 1.8VVC at present with the 1.6 fuel pump unit - no problems. Not sure how the pump would cope with 2.0L? I have no experience of this but guess if it is providing enough fuel and running OK then leave it.

If it helps I had problems when I built my car getting this pump unit to seal. The fuel seemed to seep up the threads on the fixing studs / screws and then sit on the top and around the seal. I ended up stripping the pump from the tank, degreasing and cleaning / drying....reusing the existing seal but liberally coating both sides of the seal and the threads with red hermetite sealing paste; then reassembling. It has never leaked since....not even a sniff in 9 years!

Rich

EXI Turbo 2nd June 2015 00:37

Hi Rich, I tried to find that but do not think they make it anymore. I tried Hylomar Hylolyte Red which I was told is the same stuff and also tried Hylomar Universal Blue but still leaks, even bought a brand new rubber gasket.

Just been onto ebay and bought another fuel sender unit and will try that with the sealant and see if that works.

limpabit 6th June 2015 18:13

I problem/challenge, is the fuel pump (on the turbo coupe anyway), has a separate sender unit. So needed another hole. Was an easy upgrade as well when I upgraded engine. Was not sure if original would cope.

EXI Turbo 12th June 2015 15:57

Fingers crossed the fuel leak I have had for the past two years has been sorted.

A new (secondhand) fuel sender and hylolyte red 100 was all it needed, just hope the fuel gauge is reading correctly as I do not want to take it off again to adjust.

Re comment from limpabit, how would I know if I need a more powerful pump ? Seems to work ok now, engines runs smoothly. would an undersized pump just limit the power or would it cause the engine to run roughly. Can you fit an additional unit in line ?


Arrrggghh now the clutch slave cylinder has just given up, it never seems to end 😀

limpabit 12th June 2015 17:20

Only way to know for sure, is run a fuel pressure gauge to check pressure.

If pump is not up to the job, will cause engine to run lean and cause all sorts.

As for slave, can get a cheap rebuild kit for it.

EXI Turbo 12th June 2015 18:39

Good idea about rebuild kit, just ordered from Rimmer Bros , I was about to buy a new slave cylinder so saved a few quid, thanks

I think I will leave the fuel pump alone for the time being as it seems ok, touch wood

EXI Turbo 22nd June 2015 19:59

Took the car out to Castle Combe kit at the weekend and the smell of petrol is back , it seems to be seeping out via the screw threads as mentioned by Rich.

So will need to have another go.

Other than that the car was very well behaved and the 8 seal kit sorted out my clutch problems. So all in all a very good day and a good turn out from the marlin club (I'm sure most of you can work out which one is mine !)

http://www.marlinownersclub.com/foru...7&d=1434912755

MikeN 24th June 2015 14:48

Not sure if this is relevant, but in my line of work we use PTFE tape on for high pressure solvent fittings. That is tape on the threads.

EXI Turbo 24th June 2015 21:43

do you know if that is resistant to petrol ?

I broke down on the M4 whilst on the way to the Marlin track day at Castle Combe today. Turns out that the hylolyte red 100 I used dissolved with the petrol and clogged up the fuel system.

Luckily a very helpful AA man took the fuel sender unit out and thoroughly cleaned it and then took me down to a local car spares shop to get a new fuel filter which he then fitted.

I just managed to get to Castle Combe in time to say goodbye to the Stig and get 5 laps in.

The car made it all the way home but is still leaking through the screw threads.

peterux 25th June 2015 21:24

Quote:

Originally Posted by MikeN (Post 68563)
Not sure if this is relevant, but in my line of work we use PTFE tape on for high pressure solvent fittings. That is tape on the threads.

Totally unrelated.... but I was reading the Holley (carbs,etc) website and they specifically say not to use PTFE tape for fuel line joints but they do recommend a "PTFE thread sealant".

I had never heard of PTFE thread sealant but Google and eBay lists a number of examples.
Looks like what you could be looking for?

....peter

bigrich 26th June 2015 20:52

...one thought would be Tigerseal. This polyurethane sealant is resistant to most stuff and sticks like **** to a blanket. Just don;t be in a hurry to dismantle it once sealed....sealed for life is the phrase i'd use!

Rich


All times are GMT +0. The time now is 04:16.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright Madabout Kitcars 2014