Are you madabout kit cars      
 "We've Got Kit Cars Covered" Information about Madabout-Kitcars.com Contact Madabout-Kitcars.com         Home of UK kit cars - madabout-kitcars.com Various kit car write ups All the latest kit car news Kit car related and general discussion

Search
Manufacturers
Kit Cars
Kit Car Data sheets
Picture Gallery
SVA Knowledgebase
Clubs & Communities
Build cost estimator
Kit cars for sale
Knowledge Base 
KitcarUSA.com
Classic-Kitcars.com
 

Go Back   Madabout Kitcars Forum > Mad Build Area > Tribute Automotive Builds

Tribute Automotive Builds Discuss your Tribute kit build

Reply
 
Thread Tools Display Modes
  #1  
Old 2nd September 2017, 13:44
Lucky@LeMans Lucky@LeMans is offline
Senior Member
 
Join Date: Aug 2012
Posts: 1,564
Lucky@LeMans is on a distinguished road
Default 2.2 Z3 Oil Light On

When I bought my 2.2 Z3 back in the spring the oil light was coming on from time to time . The levels were ok but I gave it an oil change and new filter. That solved the problem until a few days ago. I have noticed that after driving it hard for a few miles with it all up to temp, that the oil light comes on when I turn the ignition off. The lights stays on for about 10 seconds then goes out!

Any ideas ?
Reply With Quote
Available from eBay
  #2  
Old 2nd September 2017, 15:12
Jaguartvr's Avatar
Jaguartvr Jaguartvr is offline
Senior Member
 
Join Date: Jan 2014
Location: Egham, Surrey
Posts: 1,675
Jaguartvr is on a distinguished road
Default

I would replace the oil pressure sender unit first. Not expensive.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +0. The time now is 17:55.

copyright madabout-kitcars.com 2000-2020
terms and conditions | privacy policy