Are you madabout kit cars      
 "We've Got Kit Cars Covered" Information about Madabout-Kitcars.com Contact Madabout-Kitcars.com         Home of UK kit cars - madabout-kitcars.com Various kit car write ups All the latest kit car news Kit car related and general discussion

Search
Manufacturers
Kit Cars
Kit Car Data sheets
Picture Gallery
SVA Knowledgebase
Clubs & Communities
Build cost estimator
Kit cars for sale
Knowledge Base 
KitcarUSA.com
Classic-Kitcars.com
 

Go Back   Madabout Kitcars Forum > Mad Build Area > Sammio Builds and discussions

Sammio Builds and discussions Sammio bodied car builds and specials

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #11  
Old 29th March 2019, 18:12
micky1mo's Avatar
micky1mo micky1mo is offline
Senior Member
Enthusiast
 
Join Date: Dec 2006
Posts: 1,096
micky1mo is on a distinguished road
Default

I added a make-shift ignition loom complete with charge and oil light.



Fitted a battery and a fuel line into a temporary fuel tank.



Pressed the start button and it fired-up with very little affort!!.
It was not run for long as there's still no cooling system in place yet.
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +0. The time now is 19:32.

copyright madabout-kitcars.com 2000-2021
terms and conditions | privacy policy