Are you madabout kit cars      
 "We've Got Kit Cars Covered" Information about Madabout-Kitcars.com Contact Madabout-Kitcars.com         Home of UK kit cars - madabout-kitcars.com Various kit car write ups All the latest kit car news Kit car related and general discussion

Search
Manufacturers
Kit Cars
Kit Car Data sheets
Picture Gallery
SVA Knowledgebase
Clubs & Communities
Build cost estimator
Kit cars for sale
Knowledge Base 
KitcarUSA.com
Classic-Kitcars.com
 

Go Back   Madabout Kitcars Forum > Mad Build Area > General Build Chat

General Build Chat Area for general build chat, questions, tips, tricks and progress

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 13th September 2020, 20:05
cbjroms cbjroms is offline
Senior Member
 
Join Date: Jul 2011
Location: Hampshire
Posts: 139
cbjroms is on a distinguished road
Default Cooling System Problem

So I am running a Herald 13/60 engine in my (Sammio) kit car. The top of the radiator sits lower than the thermostat housing due to the shape of the bonnet. So, in the hose which connects the bottom of the radiator to the thermostat housing I have added a T piece, one limb of which is connected to an expansion tank. The expansion tank sits slightly higher than the top of the thermostat housing.

I was out in the car this afternoon and noticed that the temp guage was reading very high. First thought was that the temp controlled radiator fan had failed but that all checked out fine. Then I noticed that the radiator felt cooler than anything else and that the expansion tank was bubbling. I carefully removed the pressure cap from the expansion tank (it was full to the top) and lifted it higher above the engine. There was a gurgling noise, the level in the tank dropped back to normal, the radiator heated up and the fan kicked in.

I had presumed that with the exapnsion tank being higher than both the thermostat housing and radiator, any trapped air would make its way to the expansion tank. But today, the air seems to have collected in the radiator. What am I missing?

Last edited by cbjroms; 14th September 2020 at 18:31..
Reply With Quote
Available from eBay
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +0. The time now is 00:05.

copyright madabout-kitcars.com 2000-2020
terms and conditions | privacy policy