Are you madabout kit cars      
 "We've Got Kit Cars Covered" Information about Madabout-Kitcars.com Contact Madabout-Kitcars.com         Home of UK kit cars - madabout-kitcars.com Various kit car write ups All the latest kit car news Kit car related and general discussion

Search
Manufacturers
Kit Cars
Kit Car Data sheets
Picture Gallery
SVA Knowledgebase
Clubs & Communities
Build cost estimator
Kit cars for sale
Knowledge Base 
KitcarUSA.com
Classic-Kitcars.com
 

Go Back   Madabout Kitcars Forum > Mad Build Area > Sammio Builds and discussions

Sammio Builds and discussions Sammio bodied car builds and specials

Reply
 
Thread Tools Display Modes
  #41  
Old 11th April 2018, 06:42
Mick O'Malley Mick O'Malley is offline
Senior Member
 
Join Date: Nov 2012
Posts: 588
Mick O'Malley is on a distinguished road
Question

Quote:
Originally Posted by micky1mo
It's running CD150 Stromberg carbs but you can put your hand over the first carb and the car will stop. Put your hand over the second carb and the car will carry on running as-if nothing happened.
I can even screw closed both jets and the bl**dy thing still carries on running
AIR LEAKS I here you saying well NO!! Manifold is air tight, butterfly spindles are tight, new diaphragm, correct float height, new carb gaskets ect !!!!

Ditto!

I overhauled my CD150s with kits before starting the Vitesse engine I put in the A352, but, like you, it doesn't make a blind bit of difference what I do with the jets. It's reluctant to start from cold. The plugs from cylinders four, five and six are black, no matter what, but the front three are a nice milky coffee colour. Infuriatingly, it runs well once it's warm, apart from not wanting to pick up from tickover, irrespective of the speed it's set at.

I've racked up about 1600 miles so far and would very much like her to run properly. I bought an electronic ignition kit for her but haven't fitted it as in the small print (not mentioned in the advert!) it says that alternator output voltages circa 15 will burn it out. As soon as my red light goes out this is what mine produces. Aaaaaaaaaaaaagh!

Hoping some demon carb./alternator Gurus on here can offer advice!

Regards, Mick
Reply With Quote
  #42  
Old 11th April 2018, 07:54
micky1mo's Avatar
micky1mo micky1mo is offline
Senior Member
Enthusiast
 
Join Date: Dec 2006
Posts: 1,082
micky1mo is on a distinguished road
Default

This car fires up and runs fist flick of the key but it's down hill from there!!!
What electronic ignition system do you have?
Reply With Quote
  #43  
Old 11th April 2018, 13:19
Mick O'Malley Mick O'Malley is offline
Senior Member
 
Join Date: Nov 2012
Posts: 588
Mick O'Malley is on a distinguished road
Default

Quote:
Originally Posted by micky1mo View Post
This car fires up and runs fist flick of the key but it's down hill from there!!!
What electronic ignition system do you have?
It's an AccuSpark. I bought it new on Ebay for about 65, if memory serves me.
Reply With Quote
  #44  
Old 12th April 2018, 10:18
Jerome Jerome is offline
Senior Member
 
Join Date: Apr 2012
Posts: 113
Jerome is on a distinguished road
Default

I don,t have the answer,but I recognise these problems!
My carbs had different weights of dampers and my brandnew fitted diaphragm was leaking....I put in new jets and now it,s working acceptable.
Biggest change was installing a brand new,complete electronic distributor,not cheap but working so much better!
An other change was connecting a new tube from the valve cover to the inlet so it had no leaks anymore.

Maybe this will help somehowe
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +0. The time now is 02:18.

copyright madabout-kitcars.com 2000-2020
terms and conditions | privacy policy