Are you madabout kit cars      
 "We've Got Kit Cars Covered" Information about Madabout-Kitcars.com Contact Madabout-Kitcars.com         Home of UK kit cars - madabout-kitcars.com Various kit car write ups All the latest kit car news Kit car related and general discussion

Search
Manufacturers
Kit Cars
Kit Car Data sheets
Picture Gallery
SVA Knowledgebase
Clubs & Communities
Build cost estimator
Kit cars for sale
Knowledge Base 
KitcarUSA.com
Classic-Kitcars.com
 

Go Back   Madabout Kitcars Forum > Mad Build Area > Marlin 5exi builds

Marlin 5exi builds Calling all you sexi builders....sorry 5exi builders, show us your progress.

Reply
 
Thread Tools Display Modes
  #1  
Old 20th December 2017, 20:05
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default Rebuild & engine conversion

I have been very remiss in getting involved on the forum - this is my second post and I've had a my 5exi for 7 years now :S I wanted to post as I'm embarking on a new project - clearly I didn't have enough fun building her the first time around so I thought I would have another go! My chassis had sadly started to rust - pictures before and after attached - (powder coat peeling on road accessible surfaces) so I've stripped the car, shot-blasted, hot zinc sprayed & powder coated which hopefully will future-proof it for a while! I'm also taking the opportunity to switch the engine from 125bhp (AGN) to 225bhp (BAM - written off TT Quattro @ 66k ) - I hope I haven't underestimated the amount of effort this will all take, and how much more rapid the car will be when re-assembled!
Attached Images
File Type: jpg IMG_2665.jpg (91.4 KB, 41 views)
File Type: jpg IMG_2886.jpg (95.1 KB, 36 views)
Reply With Quote
Available from eBay
  #2  
Old 20th December 2017, 22:07
Leadfoot's Avatar
Leadfoot Leadfoot is offline
Member
 
Join Date: Mar 2017
Location: Doncaster, South Yorkshire
Posts: 32
Leadfoot is on a distinguished road
Default

Good luck with that! :-)

Just coming to the end of a rebuild myself. Nearly 2yrs now. No engine swap though..!
I've posted mainly on the MOC site as I didn't find out about Madabout until sometime afterward.
Reply With Quote
  #3  
Old 27th December 2017, 10:10
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

Hi and welcome

One of the decsions you are going to need to make, going from a non turbo. What type of air induction. Chargecooler or intercooler. After market ECU or recoded VAG.
Reply With Quote
  #4  
Old 28th December 2017, 21:10
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

Well done re re-build, I have my fingers crossed that I'll get it up and running in the next 6 months or so although it's probably wishful thinking...

In terms of those decisions, any advice of what works will be greatly appreciated! Given it's mid-engined and I don't wish to run boost pipes all the way to the intercooler bracket in the front I was planning on using a chargecooler and piping to a second front radiator- unless there is sufficient airflow in the back to cool sufficiently (modify the bodywork to increase airflow)? For air induction I was planning on keeping my current conical K&N air fliter (unless I've misunderstood your question...)

The wiring is going to be complicated - I currently have a recoded VAG ECU but I've just discovered the new ECU from my turbo donor car is different. If I go the recode VAG route I imagine it would be more sensible to keep the ECU that is paired to the engine and swap all the connections on the car side loom to the new ECU socket, then recode the ECU. I don't know anything about aftermarket ECUs - I imagine you get more control over the software but I don't know how easy it would be to wire up.
Reply With Quote
  #5  
Old 12th February 2018, 23:52
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

Sorry for the lack of a response.

Quote:
Originally Posted by gw302 View Post
In terms of those decisions, any advice of what works will be greatly appreciated! Given it's mid-engined and I don't wish to run boost pipes all the way to the intercooler bracket in the front I was planning on using a chargecooler and piping to a second front radiator- unless there is sufficient airflow in the back to cool sufficiently (modify the bodywork to increase airflow)? For air induction I was planning on keeping my current conical K&N air fliter (unless I've misunderstood your question...)
Yes, I went the charge cooler route. I went for the cheap mustang chargecooler from ebay which sits just behind the engine on the rear firewall. But in my experience, is not a very efficient charge cooler going by inlet temps. Not a cheap route but got most of the bits (excluding piping) from below. I would spec the chargecooler for more power than you are planning at present 300+ is quite easy to achieve on standard internals.
www.chargecooler.co.uk/

Quote:
Originally Posted by gw302 View Post
The wiring is going to be complicated - I currently have a recoded VAG ECU but I've just discovered the new ECU from my turbo donor car is different. If I go the recode VAG route I imagine it would be more sensible to keep the ECU that is paired to the engine and swap all the connections on the car side loom to the new ECU socket, then recode the ECU. I don't know anything about aftermarket ECUs - I imagine you get more control over the software but I don't know how easy it would be to wire up.
5EXI VAG owners have gone all sorts of different routes. Depending on there choice. Some have completed the own complete wiring looms. I just used the original 5EXI loom (Rover) and tapped into that with the Rover dials. Only extra for conversion I needed, was a different temperature sender to work with Rover dials. Which is just a screw in to the engine.
Aftermarket ECU will be no different wiring wise to a VAG ECU. Still need to match wire for wire where to connect up.

At this stage, you have a big discussion to make. The cost and work involved in the future, will depend on it. Stay standard'ish power or breaking the 300 barrier in the future. Wiring in standard, then have to rewire for aftermarket, redo piping for turbo etc for more power.
If over 300+, I would recommend the aftermarket ECU route. Bigger injectors, turbo, etc. Have more control for mapping (Also another cost consideration). Also very easy to data log and diagnose from ECU.

Hope that helps.
Reply With Quote
  #6  
Old 22nd April 2019, 16:37
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

It's been a long time but I thought I would give an update - have finally gotten the car back on the road! Loads of fun - especially given the hot weather

Ended up going with the original ECU (defeated immobiliser and had the EVAP/SAI/downstream lambda removed) and a chargecooler

A few things to still work out. Coolant temperature is one - does anyone run an up-rated radiator? I'm fairly sure I'm running the original rover rad. Seeing coolant temps up at 110-115C if you really push it on a hot day. I imagine this is coming close to the limit of where you want to be. Discovered, however, that if I remove the number plate from infront of the air intake and stick it to the bonnet you can get it down by 10C which is a good start!

Second issue is boost pressure, which is proving baffling. Boost is stuck on the actuator pressure (max 7psi). Logging the ECU with VCDS shows requested boost at 14psi, but the ECU doesn't control the N75 to match - the duty cycle is stuck at 0%. Engine will rev all the way to 6k, so doesn't feel like limp mode and it's not throwing any fault codes. ECU can also switch the N75 with the VCDS output test, so it doesn't appear to be wiring issue, or problem with the valve. System has also been pressure tested and no issues - it's a bit confusing!

Last edited by gw302; 22nd April 2019 at 21:21..
Reply With Quote
  #7  
Old 22nd April 2019, 16:39
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

Picture of the build:
Attached Images
File Type: jpg 20190224_085818.jpg (95.1 KB, 17 views)
Reply With Quote
  #8  
Old 22nd April 2019, 17:24
Raddog Raddog is offline
Junior Member
 
Join Date: Mar 2019
Posts: 1
Raddog is on a distinguished road
Default

Interesting thread, I’ve recently bought an EXI with a rover K Series in, car needs some sorting and once the body/suspension is sorted I think the VAG engine conversion could be a plan. I take it you’re fabricating all the bits yourself, would be interesting to hear any lessons learnt!
Reply With Quote
  #9  
Old 22nd April 2019, 21:17
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

I haven't had to do much serious fabrication - apart from the odd bit here and there: having access to a lathe/milling machine is very useful. I originally built the car with a VAG engine from a Seat Leon (normally aspirated), so the only new fabrication required this time was the boost pipes/chargecooler/intercooler rad/mounting etc (engine mounts all identical).

The reason I rebuilt was because the powder coat was starting to fail (nice excuse to put a bigger engine in while you're at it!). I had mine hot zinc sprayed and then re-coated so hopefully it will last a lot longer this time. Marlin should have the jigs for the VAG engine mounts so hopefully they can weld some up for you which would make life easier. I'm not sure if you would also have to weld tabs onto the chassis itself...

In terms of lessons learned I think they are all very individual to the build, as all the builds are different! I would say it's worth getting the cooling system routing sorted out - my first iteration kept air locking as the heater matrix was the highest point and it wasn't possible to put a sensible bleed point in without serious effort. Caused all sorts of worries as it would occasionally overheat! All in all it's a great project - but it's taken about a year and a half to get up and running again (it's quite a big job...). Happy to give more advice if/when you need it.
Reply With Quote
  #10  
Old 23rd April 2019, 07:44
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

I got a new Rover rad during the build and has never got too warm, even on hot days. Bit of an unusual size the rad. So make sure you get the right one. Fan kicks in and gives you a blast of hit air!!

Could get a manual boost valve to try.

Or check actuator rod is not too loose. Should be half a hole out from connecting pin. Then just need to pull it that half a hole to connect up.

Well done on build
Reply With Quote
  #11  
Old 23rd April 2019, 07:49
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

Thread on radiator


http://www.madabout-kitcars.com/foru...light=Radiator
Reply With Quote
  #12  
Old 23rd April 2019, 18:55
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

Thanks for the radiator thread - I'm fairly sure I'm running the same one (or something very similar). Have you had any experience with the manual boost valve? Actuator rod is good (I think it it were loose I would have an overboost problem?). I'm currently bothering all of the AUDI/VAG garages near me to see if anyone has any ideas - it would be a shame to come all this way and not be able to get it working as originally intended!
Reply With Quote
  #13  
Old 24th April 2019, 05:01
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

Did have one, when I had the Rover T16 turbo engine in the Marlin.
Is very instant with boost once it comes in. But might be a way of troubleshooting. Get a decent one as well. Have a word with Grant at GB Enterprises.

Think your right with actuator rod. But might be worth checking adjustment just to rule it out. Simple check/fix.
Reply With Quote
  #14  
Old 24th April 2019, 19:15
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

Thanks for the suggestion - had a chat with Grant and it seems like an aftermarket electronic boost controller is the most straightforward route to fixing my problem. I'll be digging around in the ECU for ages otherwise...
Reply With Quote
  #15  
Old 14th June 2019, 18:26
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

Ended up taking the car down to Grant and got it on the dyno (replaced the ECU with an aftermarket LINK ecu in the end to solve my boost issues). One thing that's come out of it is apparently the chargecooler is extremely inefficient with 220bhp being the current limit from inlet temperatures rising to 80C. Core of the barrel is 4"x10" (cylinder) which was apparently specced to 350bhp. Did you run into similar problems with your chargecooler setup?
Reply With Quote
  #16  
Old 14th June 2019, 19:09
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

Quote:
Originally Posted by gw302 View Post
Ended up taking the car down to Grant and got it on the dyno (replaced the ECU with an aftermarket LINK ecu in the end to solve my boost issues). One thing that's come out of it is apparently the chargecooler is extremely inefficient with 220bhp being the current limit from inlet temperatures rising to 80C. Core of the barrel is 4"x10" (cylinder) which was apparently specced to 350bhp. Did you run into similar problems with your chargecooler setup?
I got high inlet temps with mine as well. I put it down to a cheap mustang eBay special. Which one are you using? Yep me from chargecooler.co.uk?
Reply With Quote
  #17  
Old 14th June 2019, 19:53
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

I bought the 4"x10" kit from chargecooler.co.uk (rated there for 350bhp apparently...), David from there seems adamant that it's plenty big enough. Grant tells me it's far too small! What sort of power could you make with your setup?
Reply With Quote
  #18  
Old 14th June 2019, 20:24
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

I made 305 bhp with mine.

Wonder if itís the actual water getting too hot to cool down the air.

Wonder if itís worth plumbing in a temp sensor or a temperature gauge even temporary.
Reply With Quote
  #19  
Old 14th June 2019, 20:35
gw302's Avatar
gw302 gw302 is offline
Junior Member
 
Join Date: Mar 2011
Location: West Sussex ~ Petworth
Posts: 24
gw302 is on a distinguished road
Default

Something seems to be a little off here then: do you know what the core size of your chargecooler is? I'm told by Grant that the water isn't getting hot at all in the chargecooler - as if the internal area isn't enough to take the heat out of the air...are you still running with your mustang eBay special or have you moved on to something more heavy duty?
Reply With Quote
  #20  
Old 15th June 2019, 05:44
limpabit's Avatar
limpabit limpabit is offline
Senior Member
Enthusiast
 
Join Date: Oct 2004
Location: Basildon, Essex
Posts: 1,800
limpabit is on a distinguished road
Default

Not not upgraded it. Was going to be on the oist of things to do, but not priority.

I was going to go for one of yours.

Did Grant recommend one?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +0. The time now is 15:52.

copyright © madabout-kitcars.com 2000-2019
terms and conditions | privacy policy