Madabout Kitcars Forum

Madabout Kitcars Forum (http://www.madabout-kitcars.com/forum/index.php)
-   Marlin Sportster, Cabrio, Berlinetta and Roadster builds (http://www.madabout-kitcars.com/forum/forumdisplay.php?f=13)
-   -   E39 engine mounts (http://www.madabout-kitcars.com/forum/showthread.php?t=6644)

ChrisS 24th February 2018 12:03

E39 engine mounts
 
2 Attachment(s)
Has anyone any photos of the Marlin supplied e39/M52 engine mounting brackets, stand-alone and or correctly fitted?
I have been looking at mine and they look sufficiently “wrong” to ask the question before starting modifications, just case they have supplied the wrong ones.
Only looked at passenger side one in detail so far. Once original mount is off it doesn’t look quite as bad as I first thought as there are additional threaded holes in the engine that were obscured by the original. But will still need to slot holes by 3-4 mm and grind a lug of the engine to get it to fit. Or slot the holes slightly more and but the mount up against the lug. I have no problems opening up the holes, but slotting a hole for an M8 bolt by 5mm is enough to make me query it.
Have the question in at Marlin but no answer yet.

peterux 17th March 2018 09:19

3 Attachment(s)
Hi Chris,
I had some M52 engine mounts from Marlin about 6 years ago.
I just found some pictures which may help you?

I no longer have the mounts so can't help with any measurements etc.

ChrisS 17th March 2018 09:40

Peter thanks for these. I have actually just got a message back from Kevin at Marlin this morning agreeing that I had the wrong mounts and he would be making me a new set on Monday. Rickard had provided some photos which allowed him to identify the right jigs to use.
Slightly alarming that the jigs arent clearly identifiable as to which engine type they are for.
There are differences in the fabrication of the arms between your photos and Rickard’s, but the mounting plates and overall size, angles etc look the same from what I can see.

Thanks again.

peterux 17th March 2018 17:48

Quote:

Originally Posted by ChrisS (Post 93820)
Peter thanks for these. I have actually just got a message back from Kevin at Marlin this morning agreeing that I had the wrong mounts and he would be making me a new set on Monday. Rickard had provided some photos which allowed him to identify the right jigs to use.
Slightly alarming that the jigs arent clearly identifiable as to which engine type they are for.
There are differences in the fabrication of the arms between your photos and Rickardís, but the mounting plates and overall size, angles etc look the same from what I can see.

Thanks again.

OK, glad they are getting you sorted out.

NigelB 23rd March 2018 22:28

Quote:

Originally Posted by peterux (Post 93823)
OK, glad they are getting you sorted out.

Hi Chris,

Yes. the pictures Peterux has sent look suspiciously similar to my M50 mounts for an E36 chassis.

Glad Marlin are sorting it out for you.

Nigel

ChrisS 23rd March 2018 23:03

Replacement mounts turned up today. Unfortunately holes in LH mount are exactly the same on the new one as the old one. I can probably make some adjustments to get it to fit, but when the holes look so deliberately wrong it makes me wonder if any of it is right.


All times are GMT +0. The time now is 01:37.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright Madabout Kitcars 2014