Are you madabout kit cars      
 "We've Got Kit Cars Covered" Information about Madabout-Kitcars.com Contact Madabout-Kitcars.com         Home of UK kit cars - madabout-kitcars.com Various kit car write ups All the latest kit car news Kit car related and general discussion

Search
Manufacturers
Kit Cars
Kit Car Data sheets
Picture Gallery
SVA Knowledgebase
Clubs & Communities
Build cost estimator
Kit cars for sale
Knowledge Base 
KitcarUSA.com
Classic-Kitcars.com
 

Go Back   Madabout Kitcars Forum > Mad Build Area > Tribute Automotive Builds

Tribute Automotive Builds Discuss your Tribute kit build

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 30th June 2018, 18:43
Lucky@LeMans Lucky@LeMans is offline
Senior Member
 
Join Date: Aug 2012
Posts: 1,975
Lucky@LeMans is on a distinguished road
Default Z3 Exhaust options ( six cylinder )

Having made the most of the good weather over the last two weeks and covered a few hundred miles my exhaust has now decided to start blowing out where the down pipes attach to the main exhaust run under the foot well area at the front.
Both the flanges have corroded along with the bolts . I'm thinking about a cheap fix to see me through the summer. My options seem to be to cut off the flanges and replace them with a tube sleeve along with a couple of jubilee clips or do it properly with new parts.
What's the best option, I'm sure others have had the same issues ?
Reply With Quote
Available from eBay
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +0. The time now is 14:20.

copyright © madabout-kitcars.com 2000-2021
terms and conditions | privacy policy